このアドオンはFirefox XXX には対応していませんの回避法

このアドオンはFirefox 3.6.3 に対応していないため、インストールできませんでした。

 
Firefox4が今年の秋にリリースされるようです。

Mozilla、「Firefox 4」のビジョンを明らかに 2010年秋リリースへ

Firefoxのバージョンアップが早いのは大変ありがたいですが、毎回困るのが導入している便利なアドオンが軒並み使えなくなること。
新しいバージョンでの動作保証がないだけでそのまま使えるアドオンも多いと思われます。
このようなアドオンを入れるにはxpiファイルのバージョンチェック情報を書き換える方法があるようですが、
その互換チェック自体を簡単にOFFにできるアドオンがあるのでご紹介。

Nightly Tester Tools

タイトルバーのカスタマイズなど他にも機能があるようですが、
このアドオンを入れると強制的に旧バージョンしか対応していないアドオンをインストールすることができます。
稀に本当に互換性がなく不具合を起こし、FF自体起動しないような状態になることもあるようですが、
そのときはセーフモードでアドオンを無効にして起動しましょう。
(スタートメニューのプログラム一覧にMozilla Firefox (セーフモード)が。
またはfirefox –safe-mode をファイル名で指定して実行)

 
書いてて気付いたのはこのアドオン自体4に対応していないと無意味であること。。。